What’s Vulnerable › Vulnerabilities
CVE-2024-43129: WordPress BetterDocs plugin <= 3.5.8 - Local File Inclusion vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-13 · updated 2026-06-17
- Weakness: CWE-22
Description
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in WPDeveloper BetterDocs allows PHP Local File Inclusion.This issue affects BetterDocs: from n/a through 3.5.8.
Affected products
- WPDeveloper BetterDocs: before 3.5.9 — fixed in 3.5.9
How to fix
Upgrade to a fixed version: WPDeveloper BetterDocs 3.5.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-43129 or the next vulnerability affects your stack