What’s Vulnerable › Vulnerabilities
CVE-2024-4313: Table Addons for Elementor <= 2.1.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via _id Parameter
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The Table Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘_id’ parameter in all versions up to, and including, 2.1.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- fusionplugin Table Addons for Elementor: before 2.1.3 — fixed in 2.1.3
How to fix
Upgrade to a fixed version: fusionplugin Table Addons for Elementor 2.1.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/table-addons-for-elementor/trunk/includes/class-table-addons-for-elementor-widget.php#L637
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3104753%40table-addons-for-elementor&new=3104753%40table-addons-for-elementor&sfp_email=&sfph_mail=#file57
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ddbb4bcf-daf7-4ae3-8f42-fce5f1d2c279?source=cve
- https://plugins.trac.wordpress.org/browser/table-addons-for-elementor/trunk/includes/class-table-addons-for-elementor-widget.php#L637
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3104753%40table-addons-for-elementor&new=3104753%40table-addons-for-elementor&sfp_email=&sfph_mail=#file57
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ddbb4bcf-daf7-4ae3-8f42-fce5f1d2c279?source=cve
Get alerted when CVE-2024-4313 or the next vulnerability affects your stack