What’s Vulnerable › Vulnerabilities
CVE-2024-43150: WordPress Xpro Elementor Addons plugin <= 1.4.4.2 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-12 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Xpro Xpro Elementor Addons allows Stored XSS.This issue affects Xpro Elementor Addons: from n/a through 1.4.4.2.
Affected products
- Xpro Addons — 140+ Widgets for Elementor: before 1.4.4.3 — fixed in 1.4.4.3
How to fix
Upgrade to a fixed version: Xpro Addons — 140+ Widgets for Elementor 1.4.4.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-43150 or the next vulnerability affects your stack