What’s Vulnerable › Vulnerabilities
CVE-2024-43166
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-03 · updated 2026-06-17
- Weakness: CWE-276
Description
Incorrect Default Permissions vulnerability in Apache DolphinScheduler. This issue affects Apache DolphinScheduler: before 3.2.2. Users are recommended to upgrade to version 3.3.1, which fixes the issue.
Affected products
- Apache Software Foundation Apache DolphinScheduler: before 3.2.2 — fixed in 3.2.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache DolphinScheduler 3.2.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/8zd69zkkx55qp365xp4tml1xh9og5lhk
- http://www.openwall.com/lists/oss-security/2025/09/03/2
Get alerted when CVE-2024-43166 or the next vulnerability affects your stack