What’s Vulnerable › Vulnerabilities
CVE-2024-43202: Apache DolphinScheduler: Remote Code Execution Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-20 · updated 2026-06-17
- Weakness: CWE-94
Description
Exposure of Remote Code Execution in Apache Dolphinscheduler. This issue affects Apache DolphinScheduler: before 3.2.2. We recommend users to upgrade Apache DolphinScheduler to version 3.2.2, which fixes the issue.
Affected products
- Apache Software Foundation Apache DolphinScheduler: from 3.0.0 before 3.2.2 — fixed in 3.2.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache DolphinScheduler 3.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/apache/dolphinscheduler/pull/15758
- https://lists.apache.org/thread/nlmdp7q7l7o3l27778vxc5px24ncr5r5
- https://lists.apache.org/thread/qbhk9wqyxhrn4z7m4m343wqxpwg926nh
- https://www.cve.org/CVERecord?id=CVE-2023-49109
- http://www.openwall.com/lists/oss-security/2024/08/20/2
Get alerted when CVE-2024-43202 or the next vulnerability affects your stack