What’s Vulnerable › Vulnerabilities
CVE-2024-43204: Apache HTTP Server: SSRF with mod_headers setting Content-Type header
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-10 · updated 2026-06-17
- Weakness: CWE-918
Description
SSRF in Apache HTTP Server with mod_proxy loaded allows an attacker to send outbound proxy requests to a URL controlled by the attacker. Requires an unlikely configuration where mod_headers is configured to modify the Content-Type request or response header with a value provided in the HTTP request. Users are recommended to upgrade to version 2.4.64 which fixes this issue.
Affected products
- Apache HTTP Server: from 2.4.0 before 2.4.64 — fixed in 2.4.64
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.4.64. Check the vendor advisory for mitigations.
References
- https://httpd.apache.org/security/vulnerabilities_24.html
- http://www.openwall.com/lists/oss-security/2025/07/10/2
- http://www.openwall.com/lists/oss-security/2025/07/10/4
- https://lists.debian.org/debian-lts-announce/2025/08/msg00009.html
Get alerted when CVE-2024-43204 or the next vulnerability affects your stack