What’s Vulnerable › Vulnerabilities
CVE-2024-43227: WordPress BetterDocs – Best Documentation, FAQ & Knowledge Base Plugin with AI Support & Instant Answer for Elementor & Gutenberg plugin <= 3.5.8 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-12 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in WPDeveloper BetterDocs allows Stored XSS.This issue affects BetterDocs: from n/a through 3.5.8.
Affected products
- WPDeveloper BetterDocs: before 3.5.9 — fixed in 3.5.9
How to fix
Upgrade to a fixed version: WPDeveloper BetterDocs 3.5.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-43227 or the next vulnerability affects your stack