What’s Vulnerable › Vulnerabilities
CVE-2024-4323: Fluent Bit Memory Corruption Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 27.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-20 · updated 2026-06-17
- Weakness: CWE-122
Description
A memory corruption vulnerability in Fluent Bit versions 2.0.7 thru 3.0.3. This issue lies in the embedded http server’s parsing of trace requests and may result in denial of service conditions, information disclosure, or remote code execution.
Affected products
- FluentBit Fluent Bit: from 2.0.7 before 2.2.3; from 3.0.0 before 3.0.4 — fixed in 2.2.3, 3.0.4
How to fix
Upgrade to a fixed version: FluentBit Fluent Bit 2.2.3, 3.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/fluent/fluent-bit/commit/9311b43a258352797af40749ab31a63c32acfd04
- https://tenable.com/security/research/tra-2024-17
- https://github.com/fluent/fluent-bit/commit/9311b43a258352797af40749ab31a63c32acfd04
- https://tenable.com/security/research/tra-2024-17
- https://www.vicarius.io/vsociety/posts/linguistic-lumberjack-memory-corruption-in-fluent-bit-cve-2024-4323
Get alerted when CVE-2024-4323 or the next vulnerability affects your stack