What’s Vulnerable › Vulnerabilities
CVE-2024-43309: WordPress WP Telegram Widget and Join Link plugin <= 2.1.27 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in WP Socio WP Telegram Widget and Join Link allows Stored XSS.This issue affects WP Telegram Widget and Join Link: from n/a through 2.1.27.
Affected products
- WP Socio WP Telegram Widget and Join Link: before 2.1.28 — fixed in 2.1.28
How to fix
Upgrade to a fixed version: WP Socio WP Telegram Widget and Join Link 2.1.28. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-43309 or the next vulnerability affects your stack