What’s Vulnerable › Vulnerabilities
CVE-2024-43316: WordPress Stripe Payments For WooCommerce plugin <= 1.9.1 - Cross Site Request Forgery (CSRF) vulnerability
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-26 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in Checkout Plugins Stripe Payments For WooCommerce by Checkout.This issue affects Stripe Payments For WooCommerce by Checkout: from n/a through 1.9.1.
Affected products
- Checkout Plugins Stripe Payments For WooCommerce by Checkout: before 1.9.2 — fixed in 1.9.2
How to fix
Upgrade to a fixed version: Checkout Plugins Stripe Payments For WooCommerce by Checkout 1.9.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-43316 or the next vulnerability affects your stack