What’s Vulnerable › Vulnerabilities
CVE-2024-43318: WordPress E2Pdf – Export To Pdf Tool for WordPress plugin <= 1.25.05 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in E2Pdf e2pdf e2pdf.This issue affects e2pdf: from n/a through <= 1.25.05.
Affected products
- e2pdf: before 1.25.11 — fixed in 1.25.11
How to fix
Upgrade to a fixed version: e2pdf 1.25.11. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-43318 or the next vulnerability affects your stack