What’s Vulnerable › Vulnerabilities
CVE-2024-43335: WordPress Responsive Blocks – WordPress Gutenberg Blocks plugin <= 1.8.8 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in CyberChimps Responsive Blocks – WordPress Gutenberg Blocks allows Stored XSS.This issue affects Responsive Blocks – WordPress Gutenberg Blocks: from n/a through 1.8.8.
Affected products
- CyberChimps Responsive Blocks: before 1.8.9 — fixed in 1.8.9
How to fix
Upgrade to a fixed version: CyberChimps Responsive Blocks 1.8.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-43335 or the next vulnerability affects your stack