What’s Vulnerable › Vulnerabilities
CVE-2024-43358: XSS vulnerability in filter view
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-12 · updated 2026-06-17
- Weakness: CWE-79
Description
ZoneMinder is a free, open source closed-circuit television software application. ZoneMinder has a cross-site scripting vulnerability in the filter view via the filter[Id]. This vulnerability is fixed in 1.36.34 and 1.37.61.
Affected products
- zoneminder: before 1.36.34; from 1.37.00 before 1.37.61 — fixed in 1.36.34, 1.37.61
How to fix
Upgrade to a fixed version: zoneminder 1.36.34, 1.37.61. Check the vendor advisory for mitigations.
References
- https://github.com/ZoneMinder/zoneminder/commit/062cf568a33fb6a8604ec327b1de8bb2e0d1ff77
- https://github.com/ZoneMinder/zoneminder/commit/4602cd0470a3b90b18bcc44b3c86d963872d1ba0
- https://github.com/ZoneMinder/zoneminder/security/advisories/GHSA-6rrw-66rf-6g5f
Get alerted when CVE-2024-43358 or the next vulnerability affects your stack