What’s Vulnerable › Vulnerabilities
CVE-2024-43366: zkvyper ignored loop range bounds
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-15 · updated 2026-06-17
- Weakness: CWE-835
Description
zkvyper is a Vyper compiler. Starting in version 1.3.12 and prior to version 1.5.3, since LLL IR has no Turing-incompletness restrictions, it is compiled to a loop with a much more late exit condition. It leads to a loss of funds or other unwanted behavior if the loop body contains it. However, more real-life use cases like iterating over an array are not affected. No contracts were affected by this issue, which was fixed in version 1.5.3. Upgrading and redeploying affected contracts is the only way to avoid the vulnerability.
Affected products
- matter-labs Zkvyper: from 1.3.12 before 1.5.3 — fixed in 1.5.3
How to fix
Upgrade to a fixed version: matter-labs Zkvyper 1.5.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-43366 or the next vulnerability affects your stack