What’s Vulnerable › Vulnerabilities
CVE-2024-43370: gettext.js vulnerable to cross-site scripting (XSS)
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-16 · updated 2026-06-17
- Weakness: CWE-79
Description
gettext.js is a GNU gettext port for node and the browser. There is a cross-site scripting (XSS) injection if `.po` dictionary definition files are corrupted. This vulnerability has been patched in version 2.0.3. As a workaround, control the origin of the definition catalog to prevent the use of this flaw in the definition of plural forms.
Affected products
- guillaumepotier gettext.js: before 2.0.3
References
- https://github.com/guillaumepotier/gettext.js/commit/8150aeba833183e14c2291a8a148b8f79d1d68d8
- https://github.com/guillaumepotier/gettext.js/security/advisories/GHSA-vwhg-jwr4-vxgg
Get alerted when CVE-2024-43370 or the next vulnerability affects your stack