What’s Vulnerable › Vulnerabilities
CVE-2024-43382
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-30 · updated 2026-06-17
- Weakness: CWE-326
Description
Snowflake JDBC driver versions >= 3.2.6 and <= 3.19.1 have an Incorrect Security Setting that can result in data being uploaded to an encrypted stage without the additional layer of protection provided by client side encryption.
Affected products
- snowflakedb snowflake-jdbc: from 3.2.6 before 3.20.0 — fixed in 3.20.0
How to fix
Upgrade to a fixed version: snowflakedb snowflake-jdbc 3.20.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-43382 or the next vulnerability affects your stack