What’s Vulnerable › Vulnerabilities
CVE-2024-43383: Apache Lucene.Net.Replicator: Remote Code Execution in Lucene.Net.Replicator
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-31 · updated 2026-06-17
- Weakness: CWE-502
Description
Deserialization of Untrusted Data vulnerability in Apache Lucene.Net.Replicator. This issue affects Apache Lucene.NET's Replicator library: from 4.8.0-beta00005 through 4.8.0-beta00016. An attacker that can intercept traffic between a replication client and server, or control the target replication node URL, can provide a specially-crafted JSON response that is deserialized as an attacker-provided exception type. This can result in remote code execution or other potential unauthorized access. Users are recommended to upgrade to version 4.8.0-beta00017, which fixes the issue.
Affected products
- Apache Software Foundation Apache Lucene.Net: 4.8.0-beta00005, 4.8.0-beta00006, 4.8.0-beta00007, 4.8.0-beta00008, 4.8.0-beta00009, 4.8.0-beta00010 (+6)
References
- https://lists.apache.org/thread/wlz1p76dxpt4rl9o29voxjd5zl7717nh
- http://www.openwall.com/lists/oss-security/2024/10/31/2
Get alerted when CVE-2024-43383 or the next vulnerability affects your stack