What’s Vulnerable › Vulnerabilities
CVE-2024-43416: GLPI vulnerable to enumeration of users' email addresses by unauthenticated user
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-18 · updated 2026-06-17
- Weakness: CWE-200
Description
GLPI is a free asset and IT management software package. Starting in version 0.80 and prior to version 10.0.17, an unauthenticated user can use an application endpoint to check if an email address corresponds to a valid GLPI user. Version 10.0.17 fixes the issue.
Affected products
- glpi-project glpi: from 0.80 before 10.0.17 — fixed in 10.0.17
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.17. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/9be1466053f829680db318f7e7e5880d2d789c6d
- https://github.com/glpi-project/glpi/security/advisories/GHSA-j8gc-xpgr-2ww7
Get alerted when CVE-2024-43416 or the next vulnerability affects your stack