What’s Vulnerable › Vulnerabilities
CVE-2024-43425: Moodle: remote code execution via calculated question types
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 87.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-07 · updated 2026-06-17
- Weakness: CWE-94
Description
A flaw was found in Moodle. Additional restrictions are required to avoid a remote code execution risk in calculated question types. Note: This requires the capability to add/update questions.
Affected products
- Moodle: before 4.1.12; from 4.2.0 before 4.2.9; from 4.3.0 before 4.3.6; from 4.4.0 before 4.4.2 — fixed in 4.1.12, 4.2.9, 4.3.6, 4.4.2
How to fix
Upgrade to a fixed version: Moodle 4.1.12, 4.2.9, 4.3.6, 4.4.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2304253
- https://moodle.org/mod/forum/discuss.php?d=461193
Get alerted when CVE-2024-43425 or the next vulnerability affects your stack