What’s Vulnerable › Vulnerabilities
CVE-2024-43426: Moodle: arbitrary file read risk through pdftex
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-07 · updated 2026-06-17
- Weakness: CWE-1287
Description
A flaw was found in pdfTeX. Insufficient sanitizing in the TeX notation filter resulted in an arbitrary file read risk on sites where pdfTeX is available, such as those with TeX Live installed.
Affected products
- Moodle: from 4.1.0 before 4.1.12; from 4.2.0 before 4.2.9; from 4.3.0 before 4.3.6; from 4.4.0 before 4.4.2 — fixed in 4.1.12, 4.2.9, 4.3.6, 4.4.2
How to fix
Upgrade to a fixed version: Moodle 4.1.12, 4.2.9, 4.3.6, 4.4.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2304254
- https://moodle.org/mod/forum/discuss.php?d=461194
Get alerted when CVE-2024-43426 or the next vulnerability affects your stack