What’s Vulnerable › Vulnerabilities
CVE-2024-43427: Moodle: admin presets export tool includes some secrets that should not be exported
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-11 · updated 2026-06-17
- Weakness: CWE-922
Description
A flaw was found in moodle. When creating an export of site administration presets, some sensitive secrets and keys are not being excluded from the export, which could result in them unintentionally being leaked if the presets are shared with a third party.
Affected products
- Moodle: before 4.1.12; from 4.2.0 before 4.2.9; from 4.3.0 before 4.3.6; from 4.4.0 before 4.4.2 — fixed in 4.1.12, 4.2.9, 4.3.6, 4.4.2
How to fix
Upgrade to a fixed version: Moodle 4.1.12, 4.2.9, 4.3.6, 4.4.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2304255
- https://moodle.org/mod/forum/discuss.php?d=461195
Get alerted when CVE-2024-43427 or the next vulnerability affects your stack