What’s Vulnerable › Vulnerabilities
CVE-2024-43430: Moodle: lack of access control when using external methods for quiz overrides
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-11 · updated 2026-06-17
- Weakness: CWE-276
Description
A flaw was found in moodle. External API access to Quiz can override contained insufficient access control.
Affected products
- Moodle: from 4.4.0 before 4.4.2 — fixed in 4.4.2
How to fix
Upgrade to a fixed version: Moodle 4.4.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2304258
- https://moodle.org/mod/forum/discuss.php?d=461198
Get alerted when CVE-2024-43430 or the next vulnerability affects your stack