What’s Vulnerable › Vulnerabilities
CVE-2024-43436: Moodle: site administration sql injection via xmldb editor
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-07 · updated 2026-06-17
- Weakness: CWE-89
Description
A SQL injection risk flaw was found in the XMLDB editor tool available to site administrators.
Affected products
- Moodle: from 4.1.0 before 4.1.12; from 4.2.0 before 4.2.9; from 4.3.0 before 4.3.6; from 4.4.0 before 4.4.2 — fixed in 4.1.12, 4.2.9, 4.3.6, 4.4.2
How to fix
Upgrade to a fixed version: Moodle 4.1.12, 4.2.9, 4.3.6, 4.4.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2304264
- https://moodle.org/mod/forum/discuss.php?d=461206
Get alerted when CVE-2024-43436 or the next vulnerability affects your stack