What’s Vulnerable › Vulnerabilities
CVE-2024-4351: Tutor LMS Pro <= 2.7.0 - Missing Authorization to Privilege Escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-16 · updated 2026-06-17
- Weakness: CWE-89
Description
The Tutor LMS Pro plugin for WordPress is vulnerable to unauthorized access of data, modification of data, loss of data due to a missing capability check on the 'authenticate' function in all versions up to, and including, 2.7.0. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to gain control of an existing administrator account.
Affected products
- themeum Tutor LMS – eLearning and online course solution: before 2.7.1 — fixed in 2.7.1
How to fix
Upgrade to a fixed version: themeum Tutor LMS – eLearning and online course solution 2.7.1. Check the vendor advisory for mitigations.
References
- https://www.themeum.com/product/tutor-lms/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/59859583-49e5-4a80-8659-b9ca7ddc089d?source=cve
- https://www.themeum.com/product/tutor-lms/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/59859583-49e5-4a80-8659-b9ca7ddc089d?source=cve
Get alerted when CVE-2024-4351 or the next vulnerability affects your stack