What’s Vulnerable › Vulnerabilities
CVE-2024-4352: Tutor LMS Pro <= 2.7.0 - Missing Authorization to SQL Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-16 · updated 2026-06-17
- Weakness: CWE-862
Description
The Tutor LMS Pro plugin for WordPress is vulnerable to unauthorized access of data, modification of data, loss of data due to a missing capability check on the 'get_calendar_materials' function. The plugin is also vulnerable to SQL Injection via the ‘year’ parameter of that function due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- themeum Tutor LMS – eLearning and online course solution: before 2.7.1 — fixed in 2.7.1
How to fix
Upgrade to a fixed version: themeum Tutor LMS – eLearning and online course solution 2.7.1. Check the vendor advisory for mitigations.
References
- https://www.themeum.com/product/tutor-lms/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c647beda-cf73-4372-975f-a8c8ed05217f?source=cve
- https://www.themeum.com/product/tutor-lms/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c647beda-cf73-4372-975f-a8c8ed05217f?source=cve
Get alerted when CVE-2024-4352 or the next vulnerability affects your stack