What’s Vulnerable › Vulnerabilities
CVE-2024-4360: Element Pack Elementor Addons (Header Footer, Template Library, Dynamic Grid & Carousel, Remote Arrows) <= 5.7.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via title_tag
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The Element Pack Elementor Addons (Header Footer, Template Library, Dynamic Grid & Carousel, Remote Arrows) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's widgets in all versions up to, and including, 5.7.6 due to insufficient input sanitization and output escaping on user supplied attributes like 'title_tag'. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- bdthemes Element Pack – Widgets, Templates & Addons for Elementor: before 5.7.7 — fixed in 5.7.7
How to fix
Upgrade to a fixed version: bdthemes Element Pack – Widgets, Templates & Addons for Elementor 5.7.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/bdthemes-element-pack-lite/trunk/modules/custom-gallery/skins/skin-abetis.php#L164
- https://plugins.trac.wordpress.org/changeset/3140736/bdthemes-element-pack-lite/trunk/modules/custom-gallery/skins/skin-abetis.php
- https://plugins.trac.wordpress.org/changeset/3145280/bdthemes-element-pack-lite/trunk/modules/custom-gallery/skins/skin-abetis.php
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3140736%40bdthemes-element-pack-lite&new=3140736%40bdthemes-element-pack-lite&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/910c0a32-b169-4728-888c-0dfea2066c9c?source=cve
Get alerted when CVE-2024-4360 or the next vulnerability affects your stack