What’s Vulnerable › Vulnerabilities
CVE-2024-43601: Visual Studio Code for Linux Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-08 · updated 2026-08-19
- Weakness: CWE-77
Description
Visual Studio Code for Linux Remote Code Execution Vulnerability
Affected products
- Microsoft Visual Studio Code: before 1.94.1 — fixed in 1.94.1
- Microsoft Visual Studio Code: from 1.0.0 before 1.94.1 — fixed in 1.94.1
How to fix
Upgrade to a fixed version: Microsoft Visual Studio Code 1.94.1; Microsoft Visual Studio Code 1.94.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-43601 or the next vulnerability affects your stack