What’s Vulnerable › Vulnerabilities
CVE-2024-43613: Azure Database for PostgreSQL Flexible Server Extension Elevation of Privilege Vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-12 · updated 2026-06-17
- Weakness: CWE-77
Description
Azure Database for PostgreSQL Flexible Server Extension Elevation of Privilege Vulnerability
Affected products
- Microsoft Azure Database for PostgreSQL Flexible Server: from 12.0 before 12.20; from 13.0 before 13.16; from 14.0 before 14.13; from 15.0 before 15.8; from 16.0 before 16.4 — fixed in 12.20, 13.16, 14.13, 15.8, 16.4
- Microsoft Azure Database for PostgreSQL Flexible Server: from 16.4.0 before 16.4 — fixed in 16.4
How to fix
Upgrade to a fixed version: Microsoft Azure Database for PostgreSQL Flexible Server 12.20, 13.16, 14.13, 15.8; Microsoft Azure Database for PostgreSQL Flexible Server 16.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-43613 or the next vulnerability affects your stack