What’s Vulnerable › Vulnerabilities
CVE-2024-4366: Spectra – WordPress Gutenberg Blocks <= 2.13.0 - Authenticated (Author+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The Spectra – WordPress Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘block_id’ parameter in versions up to, and including, 2.13.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Brainstorm Force Spectra: before 2.13.1 — fixed in 2.13.1
How to fix
Upgrade to a fixed version: Brainstorm Force Spectra 2.13.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3080971/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/72a74483-e159-4c51-a9e0-4a128cbf72dd?source=cve
- https://plugins.trac.wordpress.org/changeset/3080971/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/72a74483-e159-4c51-a9e0-4a128cbf72dd?source=cve
Get alerted when CVE-2024-4366 or the next vulnerability affects your stack