What’s Vulnerable › Vulnerabilities
CVE-2024-4367
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 70.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-754
Description
A type check was missing when handling fonts in PDF.js, which would allow arbitrary JavaScript execution in the PDF.js context. This vulnerability affects Firefox < 126, Firefox ESR < 115.11, and Thunderbird < 115.11.
Affected products
- Debian Linux: 10.0
- Mozilla Firefox: before 115.11.0; before 126.0 — fixed in 115.11.0, 126.0
- Mozilla Thunderbird: before 115.11.0 — fixed in 115.11.0
- Open-Xchange Appsuite Frontend: before 7.10.6; 7.10.6, 7.10.6-revision10, 7.10.6-revision11, 7.10.6-revision12, 7.10.6-revision13, 7.10.6-revision14 (+37) — fixed in 7.10.6
How to fix
Upgrade to a fixed version: Mozilla Firefox 115.11.0, 126.0; Mozilla Thunderbird 115.11.0; Open-Xchange Appsuite Frontend 7.10.6. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1893645
- https://lists.debian.org/debian-lts-announce/2024/05/msg00010.html
- https://lists.debian.org/debian-lts-announce/2024/05/msg00012.html
- https://www.mozilla.org/security/advisories/mfsa2024-21/
- https://www.mozilla.org/security/advisories/mfsa2024-22/
- https://www.mozilla.org/security/advisories/mfsa2024-23/
- http://seclists.org/fulldisclosure/2024/Aug/30
- https://bugzilla.mozilla.org/show_bug.cgi?id=1893645
- https://codeanlabs.com/blog/research/cve-2024-4367-arbitrary-js-execution-in-pdf-js/
- https://github.com/gogs/gogs/issues/7928
- https://github.com/mozilla/pdf.js/releases/tag/v4.2.67
- https://lists.debian.org/debian-lts-announce/2024/05/msg00010.html
Get alerted when CVE-2024-4367 or the next vulnerability affects your stack