What’s Vulnerable › Vulnerabilities
CVE-2024-43700
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-29 · updated 2026-06-17
- Weakness: CWE-787
Description
xfpt versions prior to 1.01 fails to handle appropriately some parameters inside the input data, resulting in a stack-based buffer overflow vulnerability. When a user of the affected product is tricked to process a specially crafted file, arbitrary code may be executed on the user's environment.
Affected products
- Philip Hazel xfpt: before 1.01 — fixed in 1.01
How to fix
Upgrade to a fixed version: Philip Hazel xfpt 1.01. Check the vendor advisory for mitigations.
References
- https://github.com/PhilipHazel/xfpt
- https://github.com/PhilipHazel/xfpt/commit/a690304bbd3fd19e9dfdad50dcc87ad829f744e4
- https://jvn.jp/en/vu/JVNVU96498690/
- https://lists.debian.org/debian-lts-announce/2024/11/msg00034.html
Get alerted when CVE-2024-43700 or the next vulnerability affects your stack