What’s Vulnerable › Vulnerabilities
CVE-2024-43707: Kibana exposure of sensitive information to an unauthorized actor
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-23 · updated 2026-06-17
- Weakness: CWE-200
Description
An issue was identified in Kibana where a user without access to Fleet can view Elastic Agent policies that could contain sensitive information. The nature of the sensitive information depends on the integrations enabled for the Elastic Agent and their respective versions.
Affected products
- Kibana: from 8.7.0 before 8.15.0 — fixed in 8.15.0
How to fix
Upgrade to a fixed version: Kibana 8.15.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-43707 or the next vulnerability affects your stack