What’s Vulnerable › Vulnerabilities

CVE-2024-43756: Photoshop Desktop | Heap-based Buffer Overflow (CWE-122)

Description

Photoshop Desktop versions 24.7.4, 25.11 and earlier are affected by a Heap-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Affected products

How to fix

Upgrade to a fixed version: Adobe Photoshop 24.7.5, 25.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-43756 or the next vulnerability affects your stack