What’s Vulnerable › Vulnerabilities
CVE-2024-43760: Photoshop Desktop | Out-of-bounds Write (CWE-787)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-13 · updated 2026-06-17
- Weakness: CWE-787
Description
Photoshop Desktop versions 24.7.4, 25.11 and earlier are affected by an out-of-bounds write vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Photoshop: before 24.7.5; from 25.0 before 25.12 — fixed in 24.7.5, 25.12
How to fix
Upgrade to a fixed version: Adobe Photoshop 24.7.5, 25.12. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-43760 or the next vulnerability affects your stack