What’s Vulnerable › Vulnerabilities
CVE-2024-43789: Denial of service by the absence of restrictions on replies to posts in Discourse
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-07 · updated 2026-06-17
- Weakness: CWE-400
Description
Discourse is an open source platform for community discussion. A user can create a post with many replies, and then attempt to fetch them all at once. This can potentially reduce the availability of a Discourse instance. This problem has been patched in the latest version of Discourse. All users area are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- discourse: before 3.3.1; through 3.4.0 — fixed in 3.3.1
How to fix
Upgrade to a fixed version: discourse 3.3.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-43789 or the next vulnerability affects your stack