What’s Vulnerable › Vulnerabilities
CVE-2024-43793: Halo's editor has a stored XSS vulnerability
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-11 · updated 2026-06-17
- Weakness: CWE-79
Description
Halo is an open source website building tool. A security vulnerability has been identified in versions prior to 2.19.0 of the Halo project. This vulnerability allows an attacker to execute malicious scripts in the user's browser through specific HTML and JavaScript code, potentially leading to a Cross-Site Scripting (XSS) attack. This vulnerability is fixed in 2.19.0.
Affected products
- halo-dev halo: before 2.19.0 — fixed in 2.19.0
How to fix
Upgrade to a fixed version: halo-dev halo 2.19.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-43793 or the next vulnerability affects your stack