What’s Vulnerable › Vulnerabilities
CVE-2024-43797: Path Traversal in audiobookshelf
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-02 · updated 2026-06-17
- Weakness: CWE-22
Description
audiobookshelf is a self-hosted audiobook and podcast server. A non-admin user is not allowed to create libraries (or access only the ones they have permission to). However, the `LibraryController` is missing the check for admin user and thus allows a path traversal issue. Allowing non-admin users to write to any directory in the system can be seen as a form of path traversal. However, since it can be restricted to only admin permissions, fixing this is relatively simple and falls more into the realm of Role-Based Access Control (RBAC). This issue has been addressed in release version 2.13.0. All users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- advplyr audiobookshelf: before 2.13.0 — fixed in 2.13.0
How to fix
Upgrade to a fixed version: advplyr audiobookshelf 2.13.0. Check the vendor advisory for mitigations.
References
- https://github.com/advplyr/audiobookshelf-ghsa-gg56-vj58-g5mc/pull/1
- https://github.com/advplyr/audiobookshelf/blob/1c0d6e9c670ebb1b6f1e427a4c4d9250a7fb9b80/server/controllers/LibraryController.js#L43-L47
- https://github.com/advplyr/audiobookshelf/security/advisories/GHSA-gg56-vj58-g5mc
Get alerted when CVE-2024-43797 or the next vulnerability affects your stack