What’s Vulnerable › Vulnerabilities
CVE-2024-43805: HTML injection in Jupyter Notebook and JupyterLab leading to DOM Clobbering
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-28 · updated 2026-06-17
- Weakness: CWE-79
Description
jupyterlab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. This vulnerability depends on user interaction by opening a malicious notebook with Markdown cells, or Markdown file using JupyterLab preview feature. A malicious user can access any data that the attacked user has access to as well as perform arbitrary requests acting as the attacked user. JupyterLab v3.6.8, v4.2.5 and Jupyter Notebook v7.2.2 have been patched to resolve this issue. Users are advised to upgrade. There is no workaround for the underlying DOM Clobbering susceptibility. However, select plugins can be disabled on deployments which cannot update in a timely fashion to minimise the risk. These are: 1. `@jupyterlab/mathjax-extension:plugin` - users will loose ability to preview mathematical equations. 2. `@jupyterlab/markdownviewer-extension:plugin` - users will loose ability to open Markdown previews. 3. `@jupyterlab/mathjax2-extension:plugin` (if installed with optional `jupyterlab-mathjax2` package) - an older version of the mathjax plugin for JupyterLab 4.x. To disable these extensions run: ```jupyter labextension disable @jupyterlab/markdownviewer-extension:plugin && jupyter labextension disable @jupyterlab/mathjax-extension:plugin && jupyter labextension disable @jupyterlab/mathjax2-extension:plugin ``` in bash.
Affected products
- jupyterlab: before 3.6.8; from 4.0.0 before 4.2.5 — fixed in 3.6.8, 4.2.5
- jupyter notebook: from 7.0.0 before 7.2.2 — fixed in 7.2.2
How to fix
Upgrade to a fixed version: jupyterlab 3.6.8, 4.2.5; jupyter notebook 7.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-43805 or the next vulnerability affects your stack