What’s Vulnerable › Vulnerabilities
CVE-2024-43816: scsi: lpfc: Revise lpfc_prep_embed_io routine with proper endian macro usages
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-17 · updated 2026-08-04
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: lpfc: Revise lpfc_prep_embed_io routine with proper endian macro usages On big endian architectures, it is possible to run into a memory out of bounds pointer dereference when FCP targets are zoned. In lpfc_prep_embed_io, the memcpy(ptr, fcp_cmnd, sgl->sge_len) is referencing a little endian formatted sgl->sge_len value. So, the memcpy can cause big endian systems to crash. Redefine the *sgl ptr as a struct sli4_sge_le to make it clear that we are referring to a little endian formatted data structure. And, update the routine with proper le32_to_cpu macro usages.
Affected products
- Linux kernel: from 6.10 before 6.10.3 — fixed in 6.10.3
How to fix
Upgrade to a fixed version: Linux kernel 6.10.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/8bc7c617642db6d8d20ee671fb6c4513017e7a7e
- https://git.kernel.org/stable/c/9fd003f344d502f65252963169df3dd237054e49
Get alerted when CVE-2024-43816 or the next vulnerability affects your stack