What’s Vulnerable › Vulnerabilities
CVE-2024-43831: media: mediatek: vcodec: Handle invalid decoder vsi
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-17 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: media: mediatek: vcodec: Handle invalid decoder vsi Handle an invalid decoder vsi in vpu_dec_init to ensure the decoder vsi is valid for future use.
Affected products
- Linux kernel: from 4.10 before 6.1.131; from 6.2 before 6.6.44; from 6.7 before 6.10.3 — fixed in 6.1.131, 6.10.3, 6.6.44
How to fix
Upgrade to a fixed version: Linux kernel 6.1.131, 6.10.3, 6.6.44. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1c109f23b271a02b9bb195c173fab41e3285a8db
- https://git.kernel.org/stable/c/59d438f8e02ca641c58d77e1feffa000ff809e9f
- https://git.kernel.org/stable/c/cdf05ae76198c513836bde4eb55f099c44773280
- https://git.kernel.org/stable/c/dbd3e4adb98e50ede74f00b3fa956fa29ef95e6c
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2024-43831 or the next vulnerability affects your stack