What’s Vulnerable › Vulnerabilities
CVE-2024-43836: net: ethtool: pse-pd: Fix possible null-deref
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-17 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: net: ethtool: pse-pd: Fix possible null-deref Fix a possible null dereference when a PSE supports both c33 and PoDL, but only one of the netlink attributes is specified. The c33 or PoDL PSE capabilities are already validated in the ethnl_set_pse_validate() call.
Affected products
- Linux kernel: from 6.10 before 6.10.3 — fixed in 6.10.3
How to fix
Upgrade to a fixed version: Linux kernel 6.10.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4cddb0f15ea9c62f81b4889ea69a99368cc63a86
- https://git.kernel.org/stable/c/e187690b125a297499eadeec53c32c5ed6d7436a
Get alerted when CVE-2024-43836 or the next vulnerability affects your stack