What’s Vulnerable › Vulnerabilities
CVE-2024-43841: wifi: virt_wifi: avoid reporting connection success with wrong SSID
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-17 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: virt_wifi: avoid reporting connection success with wrong SSID When user issues a connection with a different SSID than the one virt_wifi has advertised, the __cfg80211_connect_result() will trigger the warning: WARN_ON(bss_not_found). The issue is because the connection code in virt_wifi does not check the SSID from user space (it only checks the BSSID), and virt_wifi will call cfg80211_connect_result() with WLAN_STATUS_SUCCESS even if the SSID is different from the one virt_wifi has advertised. Eventually cfg80211 won't be able to find the cfg80211_bss and generate the warning. Fixed it by checking the SSID (from user space) in the connection code.
Affected products
- Linux kernel: from 5.0 before 6.1.103; from 6.2 before 6.6.44; from 6.7 before 6.10.3 — fixed in 6.1.103, 6.10.3, 6.6.44
How to fix
Upgrade to a fixed version: Linux kernel 6.1.103, 6.10.3, 6.6.44. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/05c4488a0e446c6ccde9f22b573950665e1cd414
- https://git.kernel.org/stable/c/36e92b5edc8e0daa18e9325674313802ce3fbc29
- https://git.kernel.org/stable/c/416d3c1538df005195721a200b0371d39636e05d
- https://git.kernel.org/stable/c/93e898a264b4e0a475552ba9f99a016eb43ef942
- https://git.kernel.org/stable/c/994fc2164a03200c3bf42fb45b3d49d9d6d33a4d
- https://git.kernel.org/stable/c/b5d14b0c6716fad7f0c94ac6e1d6f60a49f985c7
- https://git.kernel.org/stable/c/d3cc85a10abc8eae48988336cdd3689ab92581b3
- https://lists.debian.org/debian-lts-announce/2024/10/msg00003.html
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-43841 or the next vulnerability affects your stack