What’s Vulnerable › Vulnerabilities
CVE-2024-43842: wifi: rtw89: Fix array index mistake in rtw89_sta_info_get_iter()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-17 · updated 2026-06-17
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: rtw89: Fix array index mistake in rtw89_sta_info_get_iter() In rtw89_sta_info_get_iter() 'status->he_gi' is compared to array size. But then 'rate->he_gi' is used as array index instead of 'status->he_gi'. This can lead to go beyond array boundaries in case of 'rate->he_gi' is not equal to 'status->he_gi' and is bigger than array size. Looks like "copy-paste" mistake. Fix this mistake by replacing 'rate->he_gi' with 'status->he_gi'. Found by Linux Verification Center (linuxtesting.org) with SVACE.
Affected products
- Linux kernel: from 5.16 before 6.1.103; from 6.2 before 6.6.44; from 6.7 before 6.10.3 — fixed in 6.1.103, 6.10.3, 6.6.44
How to fix
Upgrade to a fixed version: Linux kernel 6.1.103, 6.10.3, 6.6.44. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/7a0edc3d83aff3a48813d78c9cad9daf38decc74
- https://git.kernel.org/stable/c/85099c7ce4f9e64c66aa397cd9a37473637ab891
- https://git.kernel.org/stable/c/96ae4de5bc4c8ba39fd072369398f59495b73f58
- https://git.kernel.org/stable/c/a2a095c08b95372d6d0c5819b77f071af5e75366
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-43842 or the next vulnerability affects your stack