What’s Vulnerable › Vulnerabilities
CVE-2024-43912: wifi: nl80211: disallow setting special AP channel widths
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-26 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: nl80211: disallow setting special AP channel widths Setting the AP channel width is meant for use with the normal 20/40/... MHz channel width progression, and switching around in S1G or narrow channels isn't supported. Disallow that.
Affected products
- Linux kernel: before 6.1.105; from 6.2 before 6.6.46; from 6.7 before 6.10.5 — fixed in 6.1.105, 6.10.5, 6.6.46
How to fix
Upgrade to a fixed version: Linux kernel 6.1.105, 6.10.5, 6.6.46. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/23daf1b4c91db9b26f8425cc7039cf96d22ccbfe
- https://git.kernel.org/stable/c/3d42f2125f6c89e1e71c87b9f23412afddbba45e
- https://git.kernel.org/stable/c/ac3bf6e47fd8da9bfe8027e1acfe0282a91584fc
- https://git.kernel.org/stable/c/c6ea738e3feb407a3283197d9a25d0788f4f3cee
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-43912 or the next vulnerability affects your stack