What’s Vulnerable › Vulnerabilities
CVE-2024-43921: WordPress Generate Images – Magic Post Thumbnail plugin <= 5.2.9 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-29 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Magic Post Thumbnail allows Reflected XSS.This issue affects Magic Post Thumbnail: from n/a through 5.2.9.
Affected products
- Magic Post Thumbnail: before 5.2.10 — fixed in 5.2.10
How to fix
Upgrade to a fixed version: Magic Post Thumbnail 5.2.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-43921 or the next vulnerability affects your stack