What’s Vulnerable › Vulnerabilities
CVE-2024-43935: WordPress WP Delicious – Recipe Plugin for Food Bloggers (formerly Delicious Recipes) plugin <= 1.6.7 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-29 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in WP Delicious Delicious Recipes – WordPress Recipe Plugin allows Stored XSS.This issue affects Delicious Recipes – WordPress Recipe Plugin: from n/a through 1.6.7.
Affected products
- wpdelicious WP Delicious – Recipe Plugin for Food Bloggers (formerly Delicious Recipes): before 1.6.8 — fixed in 1.6.8
How to fix
Upgrade to a fixed version: wpdelicious WP Delicious – Recipe Plugin for Food Bloggers (formerly Delicious Recipes) 1.6.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-43935 or the next vulnerability affects your stack