What’s Vulnerable › Vulnerabilities
CVE-2024-43942: WordPress Greenshift Query and Meta Addon plugin < 3.9.2 - Subscriber+ SQL Injection vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-29 · updated 2026-06-17
- Weakness: CWE-89
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Wpsoul Greenshift Query and Meta Addon allows SQL Injection.This issue affects Greenshift Query and Meta Addon: from n/a before 3.9.2.
Affected products
- Wpsoul Greenshift Query and Meta Addon: before 3.9.2 — fixed in 3.9.2
How to fix
Upgrade to a fixed version: Wpsoul Greenshift Query and Meta Addon 3.9.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-43942 or the next vulnerability affects your stack