What’s Vulnerable › Vulnerabilities
CVE-2024-4395: Lack of Client Validation in Jamf Compliance Editor's Helper Service May Result in Privilege Escalation
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-27 · updated 2026-06-17
- Weakness: CWE-269
Description
The XPC service within the audit functionality of Jamf Compliance Editor before version 1.3.1 on macOS can lead to local privilege escalation.
Affected products
- Jamf Compliance Editor: from 1 before 1.3.1 — fixed in 1.3.1
How to fix
Upgrade to a fixed version: Jamf Compliance Editor 1.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/Jamf-Concepts/jamf-compliance-editor/raw/v1.3.1/Jamf%20Compliance%20Editor%20-%20User%20Guide.pdf
- https://github.com/Jamf-Concepts/jamf-compliance-editor/releases/download/v1.3.1/JamfComplianceEditor.v1.3.1.pkg
- https://khronokernel.com/macos/2024/05/01/CVE-2024-4395.html
- https://trusted.jamf.com/docs/establishing-compliance-baselines#support
- https://github.com/Jamf-Concepts/jamf-compliance-editor/raw/v1.3.1/Jamf%20Compliance%20Editor%20-%20User%20Guide.pdf
- https://github.com/Jamf-Concepts/jamf-compliance-editor/releases/download/v1.3.1/JamfComplianceEditor.v1.3.1.pkg
- https://khronokernel.com/macos/2024/05/01/CVE-2024-4395.html
- https://trusted.jamf.com/docs/establishing-compliance-baselines#support
Get alerted when CVE-2024-4395 or the next vulnerability affects your stack