What’s Vulnerable › Vulnerabilities
CVE-2024-43963: WordPress Visual CSS Style Editor plugin <= 7.6.1 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-29 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in WaspThemes YellowPencil Visual CSS Style Editor allows Reflected XSS.This issue affects YellowPencil Visual CSS Style Editor: from n/a through 7.6.1.
Affected products
- WaspThemes YellowPencil Visual CSS Style Editor: before 7.6.4 — fixed in 7.6.4
How to fix
Upgrade to a fixed version: WaspThemes YellowPencil Visual CSS Style Editor 7.6.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-43963 or the next vulnerability affects your stack