What’s Vulnerable › Vulnerabilities
CVE-2024-43999: WordPress Ninja Forms plugin <= 3.8.11 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Saturday Drive Ninja Forms allows Stored XSS.This issue affects Ninja Forms: from n/a through 3.8.11.
Affected products
- kstover Ninja Forms – The Contact Form Builder That Grows With You: before 3.8.12 — fixed in 3.8.12
How to fix
Upgrade to a fixed version: kstover Ninja Forms – The Contact Form Builder That Grows With You 3.8.12. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-43999 or the next vulnerability affects your stack